C# · 12月 19, 2021

总结易语言节点与栈的操作方法

以下就是本次我们给大家分享了易语言节点与栈的操作的实例代码和相关内容:

.版本 2

.支持库 EDataStructure

.程序集 窗口程序集1,易语言节点与栈的操作

.子程序 _按钮1_被单击

.局部变量 栈,栈

.局部变量 yyy,节点

.局部变量 zzz,节点

.局部变量 ttt,节点

.局部变量 获取栈的节点信息1,文本型

.局部变量 获取栈的节点信息2,日期时间型

yyy.加入属性 (“姓名”,“张三”)

yyy.加入属性 (“生日”,[1976年2月7日])

zzz.加入属性 (“姓名”,“李四”)

zzz.加入属性 (“生日”,[1976年12月3日])

栈.压入 (yyy)

栈.压入 (zzz)

信息框 (“栈中一共:” + 到文本 (栈.取大小 ()) + “个节点”,)

栈.弹出 (ttt)

ttt.取文本值 (“姓名”,获取栈的节点信息1)

信息框 (获取栈的节点信息1,)

ttt.取日期值 (“生日”,获取栈的节点信息2)

信息框 (获取栈的节点信息2,)

信息框 (“栈中还剩:” + 到文本 (栈.取大小 ()),)

栈.弹出 (ttt)

ttt.取文本值 (“姓名”,)

感谢大家对的支持,大家可以在本地进行测试运行。